CVE & CISA-KEV Catalog

CVE-2026-107810

HIGH
8.1
CVSS v3
NVD

Description

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, internal/backup/restore.go extracts inner archives before applying the restore_nginx and restore_nginx_ui flags and permits symlinks targeting the live Nginx configuration path. An authenticated user who can create and restore backups can craft a valid backup that places a symlink in the staging tree and then writes a regular file through that link, even when both restore flags are false. This can persistently inject configuration or cause denial of service when the modified files are later consumed. This issue is fixed in version 2.5.0.

How to fix

Remediation Available
nginx uiNVD
Affected:>= 2.0.0, < 2.5.0Fixed in:2.5.0CVE-2026-107810derived from NVD

TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works

Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.

CVSS v3 Vector

Exploitability

Attack VectorNetwork
Attack ComplexityLow
Privileges RequiredLow
User InteractionNone
ScopeUnchanged

Impact

ConfidentialityNone
IntegrityHigh
AvailabilityHigh

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploit Intelligence

0.45%probability of exploitation in 30 days
39thpercentile

Low risk: more likely to be exploited than 39% of all known CVEs.

References

Exploit1
Release Notes1

Related Vulnerabilities

Other CWE-59 (Link Following) vulnerabilities, ordered by exploit likelihood. View all

CVESeverityCVSSEPSSExploitedFix
CVE-2022-30333High7.599%KEV + RansomFix
CVE-2021-21300High8.089%-Fix
CVE-2021-32610High7.173%-Fix
CVE-2020-36193High7.571%KEVFix
CVE-2023-40028Medium4.969%-Fix
CVE-2024-57728High7.264%KEV + RansomFix

Common questions

How do I fix CVE-2026-107810?

Upgrade nginx ui to 2.5.0 or later.

Is CVE-2026-107810 being actively exploited?

Not that we know of. CVE-2026-107810 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.45% is the estimated probability that it will be exploited in the next 30 days. That is higher than 39% of all scored CVEs.

How severe is CVE-2026-107810?

CVE-2026-107810 has a CVSS v3 base score of 8.1, rated high. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.

What does CVE-2026-107810 affect?

Published advisories record a fix for nginx ui (NVD). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.

Embed a live status badge for CVE-2026-107810
CVE-2026-107810 severity badge

Markdown

[![CVE-2026-107810](https://tridentstack.com/cve/badge/CVE-2026-107810.svg)](https://tridentstack.com/cve/CVE-2026-107810)

HTML

<a href="https://tridentstack.com/cve/CVE-2026-107810"><img src="https://tridentstack.com/cve/badge/CVE-2026-107810.svg" alt="CVE-2026-107810"></a>

Find and fix vulnerabilities across your fleet

TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.

Run a free CVE scan on your fleetStart freeThis CVE lookup is free and always will be.

This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-20.