CVE & CISA-KEV Catalog

CVE-2026-85316

MEDIUM
4.8
CVSS v3
NVD

Description

Insufficient Granularity of Access Control vulnerability in Apache Camel Platform HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The component decided whether an endpoint ran in proxy mode by testing whether its configured path started with the string proxy, rather than by matching the path exactly. Any endpoint whose path merely begins with those characters - proxyStatus, proxy-config, proxying and so on - therefore became a proxy endpoint without the route author asking for it. A proxy endpoint forwards requests onward, so an endpoint that was intended to serve its own content instead relays traffic on behalf of whoever calls it, which is both a request forgery primitive and an exposure of whatever the forwarding path can reach. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. Proxy mode is now selected by an exact path match rather than by prefix. For deployments that cannot upgrade immediately, rename any endpoint path that begins with proxy but is not intended to be a proxy.

How to fix

No published remediation has been found for this vulnerability's affected products yet.

Mitigation guidance may be in the linked vendor advisories in the References section below.

TridentStack Control tracks known vulnerabilities across your Windows, macOS, and Linux fleet and shows the fix as soon as one is published. See how it works

CVSS v3 Vector

Exploitability

Attack VectorNetwork
Attack ComplexityHigh
Privileges RequiredNone
User InteractionNone
ScopeUnchanged

Impact

ConfidentialityLow
IntegrityLow
AvailabilityNone

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploit Intelligence

0.25%probability of exploitation in 30 days
16thpercentile

Low risk: more likely to be exploited than 16% of all known CVEs.

References

Related Vulnerabilities

Other CWE-1220 vulnerabilities, ordered by exploit likelihood. View all

CVESeverityCVSSEPSSExploitedFix
CVE-2025-31201Critical9.814%KEVFix
CVE-2026-33825High7.86.7%KEV + RansomFix
CVE-2024-42365High7.44.7%-Fix
CVE-2026-39363High7.53.4%-Fix
CVE-2023-43040Medium6.53.1%-Fix
CVE-2025-4404Critical9.12.0%-Fix

Common questions

How do I fix CVE-2026-85316?

No published fix for CVE-2026-85316 has been found yet. Check the linked vendor advisories for guidance as it becomes available.

Is CVE-2026-85316 being actively exploited?

Not that we know of. CVE-2026-85316 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.25% is the estimated probability that it will be exploited in the next 30 days. That is higher than 16% of all scored CVEs.

How severe is CVE-2026-85316?

CVE-2026-85316 has a CVSS v3 base score of 4.8, rated medium. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.

Embed a live status badge for CVE-2026-85316
CVE-2026-85316 severity badge

Markdown

[![CVE-2026-85316](https://tridentstack.com/cve/badge/CVE-2026-85316.svg)](https://tridentstack.com/cve/CVE-2026-85316)

HTML

<a href="https://tridentstack.com/cve/CVE-2026-85316"><img src="https://tridentstack.com/cve/badge/CVE-2026-85316.svg" alt="CVE-2026-85316"></a>

Find and fix vulnerabilities across your fleet

TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.

Run a free CVE scan on your fleetStart freeThis CVE lookup is free and always will be.

This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-19.