CVE-2026-84308
MEDIUMDescription
phpseclib is a PHP secure communications library. Prior to 3.0.57 and 4.0.1, pure-PHP X25519 scalar multiplication in phpseclib/Math/PrimeField/Integer.php performs data-dependent conditional modular reductions in add() and subtract(). During the Montgomery ladder in phpseclib/Crypt/EC/BaseCurves/Montgomery.php, the reduction behavior of each step depends on the secret scalar prefix, creating per-step timing and libgmp call-count observations that can reveal a reused 251-bit clamped private scalar. The phpseclib/Crypt/EC/Formats/Keys/MontgomeryPrivate.php derivation path invokes the pure-PHP multiplication without a native-engine check, while phpseclib/Crypt/EC/Formats/Keys/PKCS8.php reaches it when ext-sodium is unavailable. Exploitation requires a reused or long-lived X25519 private key, knowledge of the corresponding public key, execution of the pure-PHP path, and a local observer capable of resolving individual ladder steps or libgmp entry-point calls. Ephemeral X25519 keys, including phpseclib's normal SSH exchange path, are not affected. Recovery of the scalar permanently compromises operations that reuse that key. This issue is fixed in versions 3.0.57 and 4.0.1.
How to fix
TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works
Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.
CVSS v3 Vector
Exploitability
Impact
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Exploit Intelligence
Low risk: more likely to be exploited than 26% of all known CVEs.
References
Related Vulnerabilities
Other CWE-208 vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2025-53940 | Unscored | - | 4.2% | - | - |
| CVE-2019-9494 | Medium | 5.9 | 3.9% | - | Fix |
| CVE-2019-16782 | Medium | 6.3 | 3.7% | - | Fix |
| CVE-2020-1926 | Medium | 5.9 | 2.5% | - | Fix |
| CVE-2021-43298 | Critical | 9.8 | 2.3% | - | Fix |
| CVE-2022-31142 | High | 7.5 | 1.5% | - | Fix |
Common questions
How do I fix CVE-2026-84308?
Published advisories record a fix for 2 affected products. The "How to fix" section on this page lists the fixed version and source advisory for each one, so apply the entry matching what you actually run.
Is CVE-2026-84308 being actively exploited?
Not that we know of. CVE-2026-84308 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.33% is the estimated probability that it will be exploited in the next 30 days. That is higher than 26% of all scored CVEs.
How severe is CVE-2026-84308?
CVE-2026-84308 has a CVSS v3 base score of 6.3, rated medium. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
What does CVE-2026-84308 affect?
Published advisories record a fix for php-phpseclib3 (Debian), php-phpseclib4 (Debian). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.
Embed a live status badge for CVE-2026-84308
Markdown
[](https://tridentstack.com/cve/CVE-2026-84308)HTML
<a href="https://tridentstack.com/cve/CVE-2026-84308"><img src="https://tridentstack.com/cve/badge/CVE-2026-84308.svg" alt="CVE-2026-84308"></a>Check your Linux endpoints for this class of vulnerability
TridentStack Control continuously scans Linux endpoints for known vulnerabilities and deploys the fixes from the same console. 200 endpoints free forever, no credit card.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-09-09.