CVE-2026-59229
HIGHDescription
The Legacy Pipe receiver protocol (handshake / sendPipeData) uses a hardcoded SUPER_USER (root) identity when executing data loading and deletion operations. A user with only SYSTEM-level privileges (such as USE_PIPE or MAINTAIN) who does NOT have WRITE_DATA or DELETE_DATA permissions on target databases can send specially crafted PipeData messages through the Legacy Pipe API, resulting in data loading/deletion operations executed as root — effectively bypassing IoTDB's permission model entirely. This issue affects Apache IoTDB: from 2.0.0 before 2.0.11. Users are recommended to upgrade to version 2.0.11, which fixes the issue.
How to fix
No published remediation has been found for this vulnerability's affected products yet.
Mitigation guidance may be in the linked vendor advisories in the References section below.
TridentStack Control tracks known vulnerabilities across your Windows, macOS, and Linux fleet and shows the fix as soon as one is published. See how it works
CVSS v3 Vector
Exploitability
Impact
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Exploit Intelligence
Low risk: more likely to be exploited than 17% of all known CVEs.
References
Related Vulnerabilities
Other CWE-798 (Hard-coded Credentials) vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2022-26138 | Critical | 9.8 | 98% | KEV | - |
| CVE-2024-3272 | Critical | 9.8 | 98% | KEV | - |
| CVE-2024-20439 | Critical | 9.8 | 97% | KEV | Fix |
| CVE-2019-15975 | Critical | 9.8 | 96% | - | Fix |
| CVE-2025-30406 | Critical | 9.0 | 94% | KEV | Fix |
| CVE-2024-28987 | Critical | 9.1 | 93% | KEV | Fix |
Common questions
How do I fix CVE-2026-59229?
No published fix for CVE-2026-59229 has been found yet. Check the linked vendor advisories for guidance as it becomes available.
Is CVE-2026-59229 being actively exploited?
Not that we know of. CVE-2026-59229 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.26% is the estimated probability that it will be exploited in the next 30 days. That is higher than 17% of all scored CVEs.
How severe is CVE-2026-59229?
CVE-2026-59229 has a CVSS v3 base score of 8.8, rated high. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
Embed a live status badge for CVE-2026-59229
Markdown
[](https://tridentstack.com/cve/CVE-2026-59229)HTML
<a href="https://tridentstack.com/cve/CVE-2026-59229"><img src="https://tridentstack.com/cve/badge/CVE-2026-59229.svg" alt="CVE-2026-59229"></a>Find and fix vulnerabilities across your fleet
TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-30.