CVE-2026-92415
MEDIUMDescription
— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.
How to fix
TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works
Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.
CVSS v3 Vector
Exploitability
Impact
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Exploit Intelligence
Moderate risk: more likely to be exploited than 46% of all known CVEs.
References
Related Vulnerabilities
Other CWE-470 vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2021-21985 | Critical | 9.8 | 100% | KEV + Ransom | Fix |
| CVE-2024-4990 | Critical | 9.1 | 80% | - | - |
| CVE-2024-0200 | High | 7.2 | 72% | - | Fix |
| CVE-2022-30287 | High | 8.0 | 69% | - | Fix |
| CVE-2026-82078 | Critical | 9.1 | 61% | KEV | Fix |
| CVE-2025-3600 | High | 7.5 | 26% | - | - |
Common questions
How do I fix CVE-2026-92415?
Upgrade jackrabbit to 2.20.18 or later.
Is CVE-2026-92415 being actively exploited?
Not that we know of. CVE-2026-92415 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.55% is the estimated probability that it will be exploited in the next 30 days. That is higher than 46% of all scored CVEs.
How severe is CVE-2026-92415?
CVE-2026-92415 has a CVSS v3 base score of 5.3, rated medium. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
What does CVE-2026-92415 affect?
Published advisories record a fix for jackrabbit (NVD). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.
Embed a live status badge for CVE-2026-92415
Markdown
[](https://tridentstack.com/cve/CVE-2026-92415)HTML
<a href="https://tridentstack.com/cve/CVE-2026-92415"><img src="https://tridentstack.com/cve/badge/CVE-2026-92415.svg" alt="CVE-2026-92415"></a>Find and fix vulnerabilities across your fleet
TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-13.