CVE-2026-85317
MEDIUMDescription
Use of Cache Containing Sensitive Information vulnerability in Apache Camel HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The OAuth2 client token cache is global to the JVM, and its key omitted several of the fields that determine what a token actually authorises: the requested scope, the resource indicator, and the token endpoint the token was obtained from. Two endpoints differing only in those fields therefore shared a cache entry, and an endpoint could be served a token minted for a different scope, a different resource, or by a different authorization server. The consequence is a request carrying broader authority than the endpoint was configured for, or a token presented to a party it was not issued for. Reaching it requires a deployment that configures more than one OAuth2 endpoint differing in exactly those fields, which is why the severity is assessed low. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The cache key now includes every field that shapes the token, so entries are no longer shared between endpoints that differ in any of them. For deployments that cannot upgrade immediately, run endpoints that differ in scope, resource indicator or token endpoint in separate JVMs so that they do not share the cache.
How to fix
No published remediation has been found for this vulnerability's affected products yet.
Mitigation guidance may be in the linked vendor advisories in the References section below.
TridentStack Control tracks known vulnerabilities across your Windows, macOS, and Linux fleet and shows the fix as soon as one is published. See how it works
CVSS v3 Vector
Exploitability
Impact
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Exploit Intelligence
Low risk: more likely to be exploited than 19% of all known CVEs.
References
Related Vulnerabilities
Other CWE-524 vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2019-9494 | Medium | 5.9 | 3.9% | - | Fix |
| CVE-2021-24027 | High | 7.5 | 3.8% | - | Fix |
| CVE-2019-9495 | Low | 3.7 | 3.5% | - | Fix |
| CVE-2019-14997 | Medium | 4.3 | 1.2% | - | Fix |
| CVE-2026-25703 | High | 7.3 | 0.8% | - | - |
| CVE-2024-0874 | Medium | 5.3 | 0.8% | - | - |
Common questions
How do I fix CVE-2026-85317?
No published fix for CVE-2026-85317 has been found yet. Check the linked vendor advisories for guidance as it becomes available.
Is CVE-2026-85317 being actively exploited?
Not that we know of. CVE-2026-85317 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.27% is the estimated probability that it will be exploited in the next 30 days. That is higher than 19% of all scored CVEs.
How severe is CVE-2026-85317?
CVE-2026-85317 has a CVSS v3 base score of 4.8, rated medium. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
Embed a live status badge for CVE-2026-85317
Markdown
[](https://tridentstack.com/cve/CVE-2026-85317)HTML
<a href="https://tridentstack.com/cve/CVE-2026-85317"><img src="https://tridentstack.com/cve/badge/CVE-2026-85317.svg" alt="CVE-2026-85317"></a>Find and fix vulnerabilities across your fleet
TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-19.