CVE-2026-84748
HIGHDescription
Improper authorization in Apache bRPC (versions < 1.18.0) on all platforms allows remote attackers to access builtin services through the public port. Root Cause: ServerOptions.internal_port is documented to make builtin services (and Tabbed services) reachable only from the internal port, and the HTTP/h2 dispatch path enforced this. However, all protobuf-based protocol dispatch paths (baidu_std, hulu_pbrpc, sofa_pbrpc, and the nshead-based protocols public_pbrpc, nshead_mcpack, nova_pbrpc and ubrpc2pb) computed the security_mode flag but never enforced it between method resolution and method invocation. Since builtin services share the method map with user services, a client able to reach the public port could invoke builtin services such as brpc.vars or hotspots by name over these pb protocols and disclose sensitive runtime information (metrics, flags, profiler data) that the operator intended to expose only via the internal port. Affected Scenarios: Use a bRPC server with ServerOptions.internal_port configured (or with builtin/Tabbed services otherwise expected to be gated by it) while the public port is reachable from an untrusted network and any pb-based protocol is enabled. How to Fix: (Choose one of the following options) 1. Upgrade bRPC to version 1.18.0, which fixes this issue. 2. Apply this patch: https://github.com/apache/brpc/pull/3511
How to fix
No published remediation has been found for this vulnerability's affected products yet.
Mitigation guidance may be in the linked vendor advisories in the References section below.
TridentStack Control tracks known vulnerabilities across your Windows, macOS, and Linux fleet and shows the fix as soon as one is published. See how it works
CVSS v3 Vector
Exploitability
Impact
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Exploit Intelligence
Low risk: more likely to be exploited than 7% of all known CVEs.
References
Related Vulnerabilities
Other CWE-285 vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2025-29927 | Critical | 9.1 | 99% | - | Fix |
| CVE-2023-32707 | High | 8.8 | 79% | - | Fix |
| CVE-2021-28799 | Critical | 10.0 | 78% | KEV + Ransom | Fix |
| CVE-2023-48241 | High | 7.5 | 73% | - | Fix |
| CVE-2023-22480 | High | 7.3 | 67% | - | Fix |
| CVE-2022-3229 | Critical | 9.8 | 66% | - | - |
Common questions
How do I fix CVE-2026-84748?
No published fix for CVE-2026-84748 has been found yet. Check the linked vendor advisories for guidance as it becomes available.
Is CVE-2026-84748 being actively exploited?
Not that we know of. CVE-2026-84748 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.18% is the estimated probability that it will be exploited in the next 30 days. That is higher than 7% of all scored CVEs.
How severe is CVE-2026-84748?
CVE-2026-84748 has a CVSS v3 base score of 7.5, rated high. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
Embed a live status badge for CVE-2026-84748
Markdown
[](https://tridentstack.com/cve/CVE-2026-84748)HTML
<a href="https://tridentstack.com/cve/CVE-2026-84748"><img src="https://tridentstack.com/cve/badge/CVE-2026-84748.svg" alt="CVE-2026-84748"></a>Find and fix vulnerabilities across your fleet
TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-30.