CVE-2026-84316
HIGHDescription
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, config.ValidateConfigDirectives splits configuration by newline and checks only the first directive token on each line even though Nginx permits multiple semicolon-separated directives on one line. An authenticated caller can place a benign directive first and a restricted load_module, js_import, perl, or user root directive later on the same line, or can use an unrestricted include directive to load restricted content. These mechanisms bypass validation on REST, nginx_config_modify, site, and stream write paths; when an executable module is available, the injected configuration can execute code in the Nginx worker context. This issue is fixed in version 2.4.1.
How to fix
No published remediation has been found for this vulnerability's affected products yet.
Mitigation guidance may be in the linked vendor advisories in the References section below.
TridentStack Control tracks known vulnerabilities across your Windows, macOS, and Linux fleet and shows the fix as soon as one is published. See how it works
CVSS v3 Vector
Exploitability
Impact
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Exploit Intelligence
Moderate risk: more likely to be exploited than 43% of all known CVEs.
References
Related Vulnerabilities
Other CWE-20 (Improper Input Validation) vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2024-3400 | Critical | 10.0 | 100% | KEV + Ransom | - |
| CVE-2021-45105 | Medium | 5.9 | 100% | - | Fix |
| CVE-2021-44228 | Critical | 10.0 | 100% | KEV + Ransom | Fix |
| CVE-2021-21985 | Critical | 9.8 | 100% | KEV + Ransom | Fix |
| CVE-2020-3452 | High | 7.5 | 100% | KEV | Fix |
| CVE-2018-7600 | Critical | 9.8 | 100% | KEV + Ransom | Fix |
Common questions
How do I fix CVE-2026-84316?
No published fix for CVE-2026-84316 has been found yet. Check the linked vendor advisories for guidance as it becomes available.
Is CVE-2026-84316 being actively exploited?
Not that we know of. CVE-2026-84316 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.51% is the estimated probability that it will be exploited in the next 30 days. That is higher than 43% of all scored CVEs.
How severe is CVE-2026-84316?
CVE-2026-84316 has a CVSS v3 base score of 8.8, rated high. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
Embed a live status badge for CVE-2026-84316
Markdown
[](https://tridentstack.com/cve/CVE-2026-84316)HTML
<a href="https://tridentstack.com/cve/CVE-2026-84316"><img src="https://tridentstack.com/cve/badge/CVE-2026-84316.svg" alt="CVE-2026-84316"></a>Find and fix vulnerabilities across your fleet
TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-13.