CVE-2026-61627
HIGHDescription
libass is a portable subtitle renderer for the `ASS`/SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. Prior to 0.17.5, libass can overread and overwrite the glyph array in `wrap_lines_measure` while rendering malicious `ASS` content. In `wrap modes other than two`, a final line ending with a literal backslash-n sequence and otherwise consisting only of such sequences or spaces can remain after early trimming and make the line-measurement loops overshoot by one glyph. When the total text size exactly matches the allocated glyph-array capacity, the first loop reads an uninitialized 32-bit fixed-point `pos.x` value, although that value is not subsequently used. The second loop writes `pos.x` and `pos.y` beyond the array, zeroing the first and adding an attacker-controllable offset to the second. No actual exploitation beyond possible denial of service is known; broader exploitation is theoretical and constrained by the addresses, limited writes, and ASLR. This issue is fixed in version 0.17.5.
How to fix
TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works
Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.
CVSS v4 Vector
Exploitability
Impact
CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Exploit Intelligence
EPSS data unavailable for this CVE.
References
Related Vulnerabilities
Other CWE-125 (Out-of-bounds Read) vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2014-0160 | High | 7.5 | 100% | KEV | Fix |
| CVE-2025-5777 | High | 7.5 | 100% | KEV + Ransom | Fix |
| CVE-2021-4034 | High | 7.8 | 95% | KEV + Ransom | Fix |
| CVE-2026-3055 | Critical | 9.8 | 91% | KEV | Fix |
| CVE-2020-8794 | Critical | 9.8 | 89% | - | Fix |
| CVE-2023-21769 | High | 7.5 | 89% | - | Fix |
Common questions
How do I fix CVE-2026-61627?
Published advisories record a fix for 4 affected products. The "How to fix" section on this page lists the fixed version and source advisory for each one, so apply the entry matching what you actually run.
How severe is CVE-2026-61627?
CVE-2026-61627 has a CVSS v4 base score of 7.3, rated high. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
What does CVE-2026-61627 affect?
Published advisories record a fix for libass (Debian), libass (Ubuntu), libass4 (Ubuntu), libass9 (Ubuntu). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.
Embed a live status badge for CVE-2026-61627
Markdown
[](https://tridentstack.com/cve/CVE-2026-61627)HTML
<a href="https://tridentstack.com/cve/CVE-2026-61627"><img src="https://tridentstack.com/cve/badge/CVE-2026-61627.svg" alt="CVE-2026-61627"></a>Check your Linux endpoints for this class of vulnerability
TridentStack Control continuously scans Linux endpoints for known vulnerabilities and deploys the fixes from the same console. 200 endpoints free forever, no credit card.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-30.