CVE-2026-57197
HIGHDescription
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unbounded `memcpy` of `OGG/Speex` packet data in `format_ogg_speex` can cause a heap buffer overflow and crash Asterisk when reading a file containing corrupted Speex audio. The attacker must create the file and make it available to Asterisk either through sufficiently elevated privileges or by convincing an Asterisk administrator to make it available. Asterisk must also be configured to play that file. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
How to fix
TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works
Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.
CVSS v4 Vector
Exploitability
Impact
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Exploit Intelligence
Moderate risk: more likely to be exploited than 45% of all known CVEs.
References
Related Vulnerabilities
Other CWE-122 (Heap-based Buffer Overflow) vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2015-3113 | Critical | 9.8 | 100% | KEV | Fix |
| CVE-2020-25687 | Medium | 5.9 | 89% | - | Fix |
| CVE-2020-25683 | Medium | 5.9 | 89% | - | Fix |
| CVE-2024-26256 | High | 7.8 | 88% | - | Fix |
| CVE-2009-3459 | High | 8.8 | 87% | KEV | Fix |
| CVE-2021-21017 | High | 8.8 | 86% | KEV | - |
Common questions
How do I fix CVE-2026-57197?
Upgrade asterisk on debian unstable to 1:22.10.1+dfsg+~cs6.17.60671434-1 or later.
Is CVE-2026-57197 being actively exploited?
Not that we know of. CVE-2026-57197 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.53% is the estimated probability that it will be exploited in the next 30 days. That is higher than 45% of all scored CVEs.
How severe is CVE-2026-57197?
CVE-2026-57197 has a CVSS v4 base score of 7.7, rated high. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
What does CVE-2026-57197 affect?
Published advisories record a fix for asterisk (Debian). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.
Embed a live status badge for CVE-2026-57197
Markdown
[](https://tridentstack.com/cve/CVE-2026-57197)HTML
<a href="https://tridentstack.com/cve/CVE-2026-57197"><img src="https://tridentstack.com/cve/badge/CVE-2026-57197.svg" alt="CVE-2026-57197"></a>Check your Linux endpoints for this class of vulnerability
TridentStack Control continuously scans Linux endpoints for known vulnerabilities and deploys the fixes from the same console. 200 endpoints free forever, no credit card.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-28.