CVE-2026-113714
LOWDescription
virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, download_wheel() writes package-index downloads directly into the reusable wheel/house cache before selecting a verification target from pip's textual Saved output. With default-index digest comparison enabled, a controlled package index can inject a misleading Saved line through a discarded link's data-requires-python attribute; this forged-line variant also requires knowledge of an absolute path to the genuine bundled wheel. The wrong path can then be hashed, while a digest mismatch leaves the rejected archive in the cache for later selection without verification. A separate rejected-cache-file variant requires control over downloaded data or archive selection but not the forged-line prerequisites. Explicit custom-index exceptions are outside the promised PyPI comparison, and the issue does not independently bypass TLS or establish control of default PyPI. This issue is fixed in version 21.14.9.
How to fix
TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works
Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.
CVSS v4 Vector
Exploitability
Impact
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Exploit Intelligence
Low risk: more likely to be exploited than 16% of all known CVEs.
References
Related Vulnerabilities
Other CWE-354 vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2023-48795 | Medium | 5.9 | 94% | - | Fix |
| CVE-2019-1166 | Medium | 5.9 | 68% | - | - |
| CVE-2024-3596 | Critical | 9.0 | 15% | - | Fix |
| CVE-2020-26141 | Medium | 6.5 | 3.1% | - | Fix |
| CVE-2020-25862 | High | 7.5 | 2.4% | - | Fix |
| CVE-2023-38802 | High | 7.5 | 1.8% | - | Fix |
Common questions
How do I fix CVE-2026-113714?
Upgrade virtualenv to 21.14.9 or later.
Is CVE-2026-113714 being actively exploited?
Not that we know of. CVE-2026-113714 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.25% is the estimated probability that it will be exploited in the next 30 days. That is higher than 16% of all scored CVEs.
How severe is CVE-2026-113714?
CVE-2026-113714 has a CVSS v4 base score of 2.3, rated low. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
What does CVE-2026-113714 affect?
Published advisories record a fix for virtualenv (PyPI (Python)). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.
Embed a live status badge for CVE-2026-113714
Markdown
[](https://tridentstack.com/cve/CVE-2026-113714)HTML
<a href="https://tridentstack.com/cve/CVE-2026-113714"><img src="https://tridentstack.com/cve/badge/CVE-2026-113714.svg" alt="CVE-2026-113714"></a>Find and fix vulnerabilities across your fleet
TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-27.