CVE-2026-110180
MEDIUMDescription
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.
How to fix
TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works
Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.
CVSS v3 Vector
Exploitability
Impact
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Exploit Intelligence
Low risk: more likely to be exploited than 17% of all known CVEs.
References
Related Vulnerabilities
Other CWE-20 (Improper Input Validation) vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2024-3400 | Critical | 10.0 | 100% | KEV + Ransom | - |
| CVE-2021-45105 | Medium | 5.9 | 100% | - | Fix |
| CVE-2021-44228 | Critical | 10.0 | 100% | KEV + Ransom | Fix |
| CVE-2021-21985 | Critical | 9.8 | 100% | KEV + Ransom | Fix |
| CVE-2020-3452 | High | 7.5 | 100% | KEV | Fix |
| CVE-2018-7600 | Critical | 9.8 | 100% | KEV + Ransom | Fix |
Common questions
How do I fix CVE-2026-110180?
Published advisories record a fix for 2 affected products. The "How to fix" section on this page lists the fixed version and source advisory for each one, so apply the entry matching what you actually run.
Is CVE-2026-110180 being actively exploited?
Not that we know of. CVE-2026-110180 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.26% is the estimated probability that it will be exploited in the next 30 days. That is higher than 17% of all scored CVEs.
How severe is CVE-2026-110180?
CVE-2026-110180 has a CVSS v3 base score of 4.8, rated medium. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
What does CVE-2026-110180 affect?
Published advisories record a fix for node-ajv (Debian), fast-uri (npm). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.
Embed a live status badge for CVE-2026-110180
Markdown
[](https://tridentstack.com/cve/CVE-2026-110180)HTML
<a href="https://tridentstack.com/cve/CVE-2026-110180"><img src="https://tridentstack.com/cve/badge/CVE-2026-110180.svg" alt="CVE-2026-110180"></a>Check your Linux endpoints for this class of vulnerability
TridentStack Control continuously scans Linux endpoints for known vulnerabilities and deploys the fixes from the same console. 200 endpoints free forever, no credit card.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-20.