CVE-2026-110095
LOWDescription
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() functions apply RFC 3986 dot-segment removal to the path of a relative-path reference, even though that algorithm is defined only for the merged target path during resolution, so a leading parent-directory segment can be dropped and a document-relative reference can become root-relative. An application that normalizes an attacker-supplied or user-supplied relative reference and then resolves it, or uses it as a cache, deduplication, or authorization key, can have the reference escape its intended directory and point at a different resource. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, resolve a relative reference against its absolute base first and normalize the absolute result instead of normalizing the reference beforehand.
How to fix
TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works
Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.
CVSS v3 Vector
Exploitability
Impact
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Exploit Intelligence
Low risk: more likely to be exploited than 21% of all known CVEs.
References
Related Vulnerabilities
Other CWE-41 vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2025-21269 | Medium | 4.3 | 4.5% | - | Fix |
| CVE-2025-21247 | Medium | 4.3 | 3.1% | - | Fix |
| CVE-2025-21219 | Medium | 4.3 | 3.0% | - | Fix |
| CVE-2025-21189 | Medium | 4.3 | 2.9% | - | Fix |
| CVE-2024-30036 | Medium | 6.5 | 2.3% | - | Fix |
| CVE-2025-21268 | Medium | 4.3 | 1.9% | - | Fix |
Common questions
How do I fix CVE-2026-110095?
Published advisories record a fix for 2 affected products. The "How to fix" section on this page lists the fixed version and source advisory for each one, so apply the entry matching what you actually run.
Is CVE-2026-110095 being actively exploited?
Not that we know of. CVE-2026-110095 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.29% is the estimated probability that it will be exploited in the next 30 days. That is higher than 21% of all scored CVEs.
How severe is CVE-2026-110095?
CVE-2026-110095 has a CVSS v3 base score of 3.7, rated low. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
What does CVE-2026-110095 affect?
Published advisories record a fix for node-ajv (Debian), fast-uri (npm). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.
Embed a live status badge for CVE-2026-110095
Markdown
[](https://tridentstack.com/cve/CVE-2026-110095)HTML
<a href="https://tridentstack.com/cve/CVE-2026-110095"><img src="https://tridentstack.com/cve/badge/CVE-2026-110095.svg" alt="CVE-2026-110095"></a>Check your Linux endpoints for this class of vulnerability
TridentStack Control continuously scans Linux endpoints for known vulnerabilities and deploys the fixes from the same console. 200 endpoints free forever, no credit card.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-20.