CVE & CISA-KEV Catalog

CVE-2026-109449

HIGH
8.7
CVSS v4
NVD

Description

In Symfony Expression Language versions prior to 5.4.54, 6.4.48, 7.4.21, and 8.1.9, the parser of the ExpressionLanguage component built its node tree with no bound on its depth. An expression made of tens of thousands of nested unary operators, array literals, binary operators or property accesses crashed the PHP process, while the tree was being freed. #[Assert\ExpressionSyntax] passes the validated value to ExpressionLanguage::lint(), so an application validating expressions written by its users could be crashed by a single request, and so could any code parsing untrusted expressions. This issue affects symfony/expression-language through v5.4.53, v6.0.0-BETA1 through v6.4.47, v7.0.0-BETA1 through v7.4.20, and v8.0.0-BETA1 through v8.1.8.

How to fix

Remediation Available
symfonyDebian
Fixed in:7.4.21+dfsg-1CVE-2026-109449

TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works

Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.

CVSS v4 Vector

Exploitability

Attack VectorNetwork
Attack ComplexityLow
Privileges RequiredNone
User InteractionNone

Impact

CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Exploit Intelligence

0.38%probability of exploitation in 30 days
32ndpercentile

Low risk: more likely to be exploited than 32% of all known CVEs.

References

Related Vulnerabilities

Other CWE-674 vulnerabilities, ordered by exploit likelihood. View all

CVESeverityCVSSEPSSExploitedFix
CVE-2021-45105Medium5.9100%-Fix
CVE-2024-25111High8.665%-Fix
CVE-2023-50269High8.658%-Fix
CVE-2021-42697High7.536%-Fix
CVE-2007-1285High7.519%-Fix
CVE-2018-0739Medium6.519%-Fix

Common questions

How do I fix CVE-2026-109449?

Upgrade symfony on debian unstable to 7.4.21+dfsg-1 or later.

Is CVE-2026-109449 being actively exploited?

Not that we know of. CVE-2026-109449 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.38% is the estimated probability that it will be exploited in the next 30 days. That is higher than 32% of all scored CVEs.

How severe is CVE-2026-109449?

CVE-2026-109449 has a CVSS v4 base score of 8.7, rated high. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.

What does CVE-2026-109449 affect?

Published advisories record a fix for symfony (Debian). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.

Embed a live status badge for CVE-2026-109449
CVE-2026-109449 severity badge

Markdown

[![CVE-2026-109449](https://tridentstack.com/cve/badge/CVE-2026-109449.svg)](https://tridentstack.com/cve/CVE-2026-109449)

HTML

<a href="https://tridentstack.com/cve/CVE-2026-109449"><img src="https://tridentstack.com/cve/badge/CVE-2026-109449.svg" alt="CVE-2026-109449"></a>

Check your Linux endpoints for this class of vulnerability

TridentStack Control continuously scans Linux endpoints for known vulnerabilities and deploys the fixes from the same console. 200 endpoints free forever, no credit card.

Patch your fleet freeStart freeThis CVE lookup is free and always will be.

This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-16.