CVE & CISA-KEV Catalog

CVE-2026-109413

HIGH
8.7
CVSS v4
NVD

Description

In Symfony YAML prior to versions 5.4.54, 6.4.45, 7.4.18, and 8.1.6, Yaml\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting level that the rest of the parser bounds with maxNestingLevel. A document made of deeply nested inline collections, such as [[[[...]]]], exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error. Any code parsing untrusted YAML is affected. That includes #[MapRequestPayload] when the Yaml component is installed and the endpoint does not restrict acceptFormat: a single unauthenticated request with a YAML content type is enough. This issue affects symfony/yaml through v5.4.53, v6.0.0-BETA1 through v6.4.44, v7.0.0-BETA1 through v7.4.17, and v8.0.0-BETA1 through v8.1.5.

How to fix

Remediation Available
symfonyDebian
Fixed in:7.4.18+dfsg-1CVE-2026-109413

TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works

Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.

CVSS v4 Vector

Exploitability

Attack VectorNetwork
Attack ComplexityLow
Privileges RequiredNone
User InteractionNone

Impact

CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Exploit Intelligence

0.40%probability of exploitation in 30 days
34thpercentile

Low risk: more likely to be exploited than 34% of all known CVEs.

References

Related Vulnerabilities

Other CWE-674 vulnerabilities, ordered by exploit likelihood. View all

CVESeverityCVSSEPSSExploitedFix
CVE-2021-45105Medium5.9100%-Fix
CVE-2024-25111High8.665%-Fix
CVE-2023-50269High8.658%-Fix
CVE-2021-42697High7.536%-Fix
CVE-2007-1285High7.519%-Fix
CVE-2018-0739Medium6.519%-Fix

Common questions

How do I fix CVE-2026-109413?

Upgrade symfony on debian unstable to 7.4.18+dfsg-1 or later.

Is CVE-2026-109413 being actively exploited?

Not that we know of. CVE-2026-109413 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.40% is the estimated probability that it will be exploited in the next 30 days. That is higher than 34% of all scored CVEs.

How severe is CVE-2026-109413?

CVE-2026-109413 has a CVSS v4 base score of 8.7, rated high. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.

What does CVE-2026-109413 affect?

Published advisories record a fix for symfony (Debian). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.

Embed a live status badge for CVE-2026-109413
CVE-2026-109413 severity badge

Markdown

[![CVE-2026-109413](https://tridentstack.com/cve/badge/CVE-2026-109413.svg)](https://tridentstack.com/cve/CVE-2026-109413)

HTML

<a href="https://tridentstack.com/cve/CVE-2026-109413"><img src="https://tridentstack.com/cve/badge/CVE-2026-109413.svg" alt="CVE-2026-109413"></a>

Check your Linux endpoints for this class of vulnerability

TridentStack Control continuously scans Linux endpoints for known vulnerabilities and deploys the fixes from the same console. 200 endpoints free forever, no credit card.

Patch your fleet freeStart freeThis CVE lookup is free and always will be.

This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-16.