CVE-2026-101296
CRITICALDescription
A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.
How to fix
TridentStack Control can deploy fixes like this automatically across your Windows, macOS, and Linux fleet. See how it works
Remediation is compiled from vendor and distribution security advisories. Always confirm against the linked source for your exact version and platform.
CVSS v4 Vector
Exploitability
Impact
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Exploit Intelligence
Moderate risk: more likely to be exploited than 50% of all known CVEs.
References
Related Vulnerabilities
Other CWE-304 vulnerabilities, ordered by exploit likelihood. View all
| CVE | Severity | CVSS | EPSS | Exploited | Fix |
|---|---|---|---|---|---|
| CVE-2023-54391 | Critical | 9.8 | 3.0% | - | - |
| CVE-2022-1065 | High | 8.1 | 2.9% | - | Fix |
| CVE-2026-55957 | High | 7.3 | 2.9% | - | Fix |
| CVE-2022-2302 | Critical | 9.8 | 2.1% | - | Fix |
| CVE-2024-2172 | Critical | 9.8 | 1.7% | - | - |
| CVE-2019-16766 | High | 8.7 | 1.5% | - | Fix |
Common questions
How do I fix CVE-2026-101296?
Upgrade tomcat9 on debian 12 to 9.0.70-2 or later.
Is CVE-2026-101296 being actively exploited?
Not that we know of. CVE-2026-101296 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 0.63% is the estimated probability that it will be exploited in the next 30 days. That is higher than 50% of all scored CVEs.
How severe is CVE-2026-101296?
CVE-2026-101296 has a CVSS v4 base score of 9.1, rated critical. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.
What does CVE-2026-101296 affect?
Published advisories record a fix for tomcat9 (Debian). Only products with a sourced advisory are listed, so treat this as what we can cite rather than a complete inventory.
Embed a live status badge for CVE-2026-101296
Markdown
[](https://tridentstack.com/cve/CVE-2026-101296)HTML
<a href="https://tridentstack.com/cve/CVE-2026-101296"><img src="https://tridentstack.com/cve/badge/CVE-2026-101296.svg" alt="CVE-2026-101296"></a>Check your Linux endpoints for this class of vulnerability
TridentStack Control continuously scans Linux endpoints for known vulnerabilities and deploys the fixes from the same console. 200 endpoints free forever, no credit card.
This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2026-10-21.