CVE & CISA-KEV Catalog

CVE-2024-31141

MEDIUMEPSS 71th pctl
6.5
CVSS v3
NVD

Description

Files or Directories Accessible to External Parties, Improper Privilege Management vulnerability in Apache Kafka Clients. Apache Kafka Clients accept configuration data for customizing behavior, and includes ConfigProvider plugins in order to manipulate these configurations. Apache Kafka also provides FileConfigProvider, DirectoryConfigProvider, and EnvVarConfigProvider implementations which include the ability to read from disk or environment variables. In applications where Apache Kafka Clients configurations can be specified by an untrusted party, attackers may use these ConfigProviders to read arbitrary contents of the disk and environment variables. In particular, this flaw may be used in Apache Kafka Connect to escalate from REST API access to filesystem/environment access, which may be undesirable in certain environments, including SaaS products. This issue affects Apache Kafka Clients: from 2.3.0 through 3.5.2, 3.6.2, 3.7.0. Users with affected applications are recommended to upgrade kafka-clients to version >=3.8.0, and set the JVM system property "org.apache.kafka.automatic.config.providers=none". Users of Kafka Connect with one of the listed ConfigProvider implementations specified in their worker config are also recommended to add appropriate "allowlist.pattern" and "allowed.paths" to restrict their operation to appropriate bounds. For users of Kafka Clients or Kafka Connect in environments that trust users with disk and environment variable access, it is not recommended to set the system property. For users of the Kafka Broker, Kafka MirrorMaker 2.0, Kafka Streams, and Kafka command-line tools, it is not recommended to set the system property.

How to fix

No published remediation has been found for this vulnerability's affected products yet.

Mitigation guidance may be in the linked vendor advisories in the References section below.

TridentStack Control tracks known vulnerabilities across your Windows, macOS, and Linux fleet and shows the fix as soon as one is published. See how it works

CVSS v3 Vector

Exploitability

Attack VectorNetwork
Attack ComplexityLow
Privileges RequiredLow
User InteractionNone
ScopeUnchanged

Impact

ConfidentialityHigh
IntegrityNone
AvailabilityNone

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploit Intelligence

1.33%probability of exploitation in 30 days
71stpercentile

Elevated risk: more likely to be exploited than 71% of all known CVEs.

References

Vendor Advisory1
Third-Party Advisory2

Related Vulnerabilities

Other CWE-269 (Improper Privilege Management) vulnerabilities, ordered by exploit likelihood. View all

CVESeverityCVSSEPSSExploitedFix
CVE-2017-12635Critical9.8100%-Fix
CVE-2022-24637Critical9.899%-Fix
CVE-2017-5689Critical9.892%KEVFix
CVE-2021-20021Critical9.889%KEV + RansomFix
CVE-2020-3243Critical9.888%--
CVE-2024-21888High8.885%--

Common questions

How do I fix CVE-2024-31141?

No published fix for CVE-2024-31141 has been found yet. Check the linked vendor advisories for guidance as it becomes available.

Is CVE-2024-31141 being actively exploited?

Not that we know of. CVE-2024-31141 is not in the CISA Known Exploited Vulnerabilities catalog. Its EPSS score of 1.3% is the estimated probability that it will be exploited in the next 30 days. That is higher than 71% of all scored CVEs.

How severe is CVE-2024-31141?

CVE-2024-31141 has a CVSS v3 base score of 6.5, rated medium. CVSS rates the technical impact if the vulnerability is exploited, not how likely that is, so weigh it alongside the exploit-prediction score when you decide what to patch first.

Embed a live status badge for CVE-2024-31141
CVE-2024-31141 severity badge

Markdown

[![CVE-2024-31141](https://tridentstack.com/cve/badge/CVE-2024-31141.svg)](https://tridentstack.com/cve/CVE-2024-31141)

HTML

<a href="https://tridentstack.com/cve/CVE-2024-31141"><img src="https://tridentstack.com/cve/badge/CVE-2024-31141.svg" alt="CVE-2024-31141"></a>

Find and fix vulnerabilities across your fleet

TridentStack Control continuously scans your Windows, macOS, and Linux fleet for known vulnerabilities, prioritizes them by severity and active exploitation, and patches them automatically.

Run a free CVE scan on your fleetStart freeThis CVE lookup is free and always will be.

This product uses NVD data but is not endorsed or certified by the NVD. EPSS scores courtesy of FIRST.org (https://www.first.org/epss). Source: CISA KEV Catalog. Data as of 2025-07-15.